General Auto Related Help Area Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

1996 900 bizarre electrical problems

 
Old 02-10-2012, 10:24 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Feb 2012
Posts: 2
Default 1996 900 bizarre electrical problems

I really don’t know where to post this topic, so I’ll start here.
I’m new to this forum & to Saabs in general, so bear with me please.

Problems:
(1) left headlight is “dimmer” than the right one, but only intermittently.
In other words, when it does work – sometimes it doesn’t at all - it functions not as bright as it should.

(2) Right brake light also operates only intermittently.
I constantly get the error notice on the display during startup “checking” sequence.
Yet, there are times when it is working fine.

All bulbs are new…functioning OK
All fuses are functioning OK
Milage = 216,000
New alternator / generator two years ago.

Has anyone else encountered this problem…or one like it ?
utahman is offline  
Old 02-11-2012, 07:54 PM
  #2  
Junior Member
 
Join Date: Feb 2012
Posts: 7
Default electrical problems

This is more than likel unrelated as the 2 cars are so different. Anyway i had this same problem in my 1998 dodge ram, it ended up being a relay switch, again probably not but its worth a try.
BOOSH is offline  
Old 02-11-2012, 08:15 PM
  #3  
Junior Member
 
Join Date: Feb 2012
Posts: 7
Default other idea...

My Friend just told me to tell you that it sounds like a faulty ground wire, he said check and if needed replace the grounds and they should brighten up.
BOOSH is offline  
Old 02-11-2012, 09:00 PM
  #4  
Junior Member
 
Join Date: Feb 2012
Posts: 1
Cool

Originally Posted by utahman View Post
I really don’t know where to post this topic, so I’ll start here.
I’m new to this forum & to Saabs in general, so bear with me please.

Problems:
(1) left headlight is “dimmer” than the right one, but only intermittently.
In other words, when it does work – sometimes it doesn’t at all - it functions not as bright as it should.

(2) Right brake light also operates only intermittently.
I constantly get the error notice on the display during startup “checking” sequence.
Yet, there are times when it is working fine.

All bulbs are new…functioning OK
All fuses are functioning OK
Milage = 216,000
New alternator / generator two years ago.

Has anyone else encountered this problem…or one like it ?
Just like boosh said I told him. Most likely considering the miles the car has seen. You are experiencing electrical problems. The head light that is dim, take the ground wire and cut it, but leave some length so you can ground it to the core support or even the fender will do. that should solve that problem. Then do the same for your tail light. If the problem persists post back and I'll try to help. Good luck!
VlkWgnDave is offline  
Old 02-12-2012, 08:10 AM
  #5  
Junior Member
Thread Starter
 
Join Date: Feb 2012
Posts: 2
Default

Originally Posted by VlkWgnDave View Post
Just like boosh said I told him. Most likely considering the miles the car has seen. You are experiencing electrical problems. The head light that is dim, take the ground wire and cut it, but leave some length so you can ground it to the core support or even the fender will do. that should solve that problem. Then do the same for your tail light. If the problem persists post back and I'll try to help. Good luck!
thank yor for the reply ...

excellent advice, i'll see what i can do here.
hopefully it's not a relay switch, re-working the wires seems like a better option.

i assume the ground wires are black ?
utahman is offline  
Old 02-12-2012, 10:13 AM
  #6  
Junior Member
 
Join Date: Feb 2012
Posts: 7
Default ground wire color

they are not always black, try to find a wire scematic for your vehicle.
BOOSH is offline  
Old 03-29-2013, 05:09 AM
  #7  
Junior Member
 
Join Date: Mar 2013
Posts: 1
Default

Thank you for sharing your information.
brand33 is offline  
Old 04-02-2013, 01:34 PM
  #8  
Junior Member
 
Join Date: Apr 2013
Posts: 2
Default

Usually the headlight problem is related to the orange relay inside the engine compartment fuse relay box. On European cars the ground wires are usually brown, black wires are hot with the ignition, and red wires are hot all of the time.
NoelReitz is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
sparks
New Member Area
3
11-30-2009 08:37 PM
cookster
New Member Area
0
01-09-2009 03:22 PM
jdfischer
1994-1994 900
13
05-15-2008 10:22 AM
9000Aeroguy1
General Auto Related Help Area
2
07-25-2006 05:30 AM
hjmer
PRIVATE For Sale / Trade Classifieds
0
05-22-2006 04:35 AM


Thread Tools
Search this Thread
Quick Reply: 1996 900 bizarre electrical problems


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.