Ive searched, and searched. Help

 
Old 11-08-2010, 06:39 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Nov 2010
Posts: 1
Default Ive searched, and searched. Help

Ok. My wife and I just bought a 00' 9-3 2.0t. Now when we got it, It wouldnt boost well maybe to 1-2psi.
Also when we first start it in the morning, It rev's up and down very very ruff. I ran codes this morning, Didnt have a pen to write them down tho. If I remember rite a 1604, And a Code that Said multipule miss fire.

Now it does this for about 2-3 minutes and then once it starts to warm up just comes rite out of it, and runs smooth.

As far as the boost. I did this
http://www.saabwiki.info/index.php?t..._Control_Valve
What it did by removing the bottom 2 hoses is it Made it come alive its now boosting a 1/4 way into the yellow. But studders when pressing the happy peddle. No matter if boost is 2/3rds into the green or in the yellow. And I have kept it this way because atleast the car can get out of its own way now.

I also Tried this, No differance-Left it plugged off
http://www.saabcentral.com/forums/sh...d.php?t=106554


So, I know this post is confusing.
TO recap-
Ruff idle on start up, evens out after 3 minutes and runs smooth the rest of the day. Starts up smooth, Only does it after sitting a long period (Over night)
Low Boost intil I did the first link test and it went from little boost to 1/4 way in the yellow. But I am still getting "bucking" or "stuttering" maybe fuel cut?


What Could this be The BPC valve? DI? Maf? Or?

Im Lost, And need some guidence.

Thanks everyone.
Al
AllanR is offline  
 


Thread Tools
Search this Thread

Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.