1999 9-3 Hard to Start

 
Old 09-07-2010, 08:07 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Sep 2010
Posts: 2
Default 1999 9-3 Hard to Start

I just purhcased a 1999 9-3. When I test drove it, it started fine (I guess it was warm already). When its cold it is very hard to start, it justs turning over and over on the starter motor, then coughs a bit and finally comes to life. I think pumping the throttle helps.

What would this possible be ? I read maybe the fuel pump ? When I put the ignition on the pump sounds fine and the car drives completely fine once it is running.

It does have the famous oil leak from the head / block area ... perhaps some oil is also going back into the cylinder making it hard to start ? I'll be torquing that this weekend anyway.
stevessaab is offline  
Old 09-08-2010, 06:52 PM
  #2  
Junior Member
Thread Starter
 
Join Date: Sep 2010
Posts: 2
Default Update

As an update to this little issue. I find that if I key the ignition, wait for 5 seconds, pump the throttle 2 times and then try to start it, it starts pretty easy.

Also sometimes when I put the ignition on, the fuel pump runs, but dosn't stop. Normally it will run for a couple of seconds and stop, but its just running continuously somtimes .... I'm thinking the pump its on the way out and it can't build enough pressure, but I'll check the filter first, maybe thats all it is.

Noticed another small issue, my wiper blade goes too far and hits the trim around the window .. hopefully there is some adjustment in the motor/mechanism to solve that one.

Last edited by stevessaab; 09-08-2010 at 07:35 PM.
stevessaab is offline  
 


Thread Tools
Search this Thread

Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.