2003 9-3 arc alternator woes

 
Old 01-28-2011, 12:32 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Jan 2011
Posts: 1
Default 2003 9-3 arc alternator woes

I am trying to troubleshoot an alternator issue on my 2003 9-3. Problem started with low battery with corresponding faults (gearbox failure/abs/tcs/etc..)Found battery voltage low. Replaced battery, next day same problem. Replaced alternator, fully charged battery, now getting "battery not charging" SID message. At alternator output lead only reading battery voltage when engine running. At two lead connector am receiving approx. 12vdc on one lead, the other has no voltage, these are wires coming from the ecm. I'm assuming the 12vdc is the excitation voltage, (these alt. are not self exciting). I'm not sure what the other is supposed to be. These are the "l" and "f" inputs from the ecm. Any ideas what the inputs should be? I'm leaning towards bad alternator? Just don't want to pull the trigger on removing it again! Thanks for any help.
alazzurra is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
gmac1201
General Auto Related Help Area
2
11-29-2009 03:30 PM


Thread Tools
Search this Thread
Quick Reply: 2003 9-3 arc alternator woes


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.