2005 9-3 starting problems

 
Old 05-14-2011, 11:48 AM
  #1  
Junior Member
Thread Starter
 
Join Date: May 2011
Posts: 3
Default 2005 9-3 starting problems

Recently my '05 9-3 Aero developed a strange starting problem. Sometimes the key will not turn and the car electrical seems dead. Charging the battery will allow the car to start and sometimes will not start again after being turned off.

I went to my local Advance Auto Parts and had the battery load checked and gave the following results:

Voltage: 12.59
Measured: 693 CCA
Rated: 650 CCA
Temperature: 118 F

So I didn't replace the battery and drove the car home. Has anyone had a similar problem?
trebor is offline  
Old 05-23-2011, 03:49 PM
  #2  
Junior Member
 
Join Date: May 2011
Location: New Hampshire
Posts: 3
Default

If the key won't turn, it could simply be the battery in you key fob. If the key fob battery is new, then the key/ignition switch might be bad, or it could be a bad solenoid. Start with checking the battery in the fob.
Audi Dan is offline  
Old 06-14-2012, 03:40 PM
  #3  
Junior Member
 
Join Date: Jun 2012
Posts: 4
Default

same problem but get multi errors they clear up after i turn off then back on. dash lights flicker? key is good, I did replaced the battery and alternator but no luck? any ideas? the battery appears to be dead but had the new battery and alternator rechecked and they were good? running out of ideas?? any ideas anyone???
jalvigil is offline  
Old 06-15-2012, 12:48 PM
  #4  
Junior Member
Thread Starter
 
Join Date: May 2011
Posts: 3
Default Fixed!

Finally cured my problem by cleaning out the keyhole using cotton swabs and rubbing alcohol.
trebor is offline  
Old 06-18-2012, 11:14 AM
  #5  
Junior Member
 
Join Date: Jun 2012
Posts: 4
Default

quick question did your car seem to be dead at times but started after a short while after sitting. as far as my symtoms the edit dome lights flicker the dash odometer flickers, somtimes it gives random errors, weird symtoms? i do believe it has to be something that effects everything do these symtoms sound familer to you?? oh yah also when you reset the car by taking the neg cable off the car starts right up for alittle bit. just asking because this problem is a head ach lol your direction will be of great help thanks. And if anyone else had these promblems please respond if i find out anything i will post all solutions to help others out as well thanks

Last edited by IB QA; 11-16-2018 at 05:44 PM. Reason: Testing
jalvigil is offline  
Old 06-19-2012, 07:27 AM
  #6  
Junior Member
Thread Starter
 
Join Date: May 2011
Posts: 3
Default

Had kinds of strange things going on like the gauges moving throughout their range, dead battery symptoms, ecu messages, etc. A battery jump would always allow it to start and drive normally but would never lastand it never died while driving unless I turned it off. The last thing I tried was to clean the key hole and key and that has been over a year ago and has never returned. Good luck!
trebor is offline  
Old 06-20-2012, 02:23 PM
  #7  
Junior Member
 
Join Date: Jun 2012
Posts: 4
Default

I will give it a try ok . I really appreciate your direction i will post the outcome thanks again.
jalvigil is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dbaker4572
New Member Area
15
01-09-2013 09:26 PM
96sheepdog
Saab 9-3
0
09-08-2010 06:11 PM
jawadelanis
Saab 9-3
2
08-26-2010 02:34 PM
SageRhys
PRIVATE For Sale / Trade Classifieds
0
07-28-2007 08:41 PM
Autogeek
Detailing
0
07-29-2005 01:01 PM


Thread Tools
Search this Thread
Quick Reply: 2005 9-3 starting problems


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.