Car won't start after car wash

 
Old 07-07-2013, 02:46 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Jul 2013
Posts: 1
Default Car won't start after car wash

Hi, I'm new so I hope this is the right place for this post. I have a 2010 9-3 aero and after driving home from the car wash the car won't start. I tested the battery and it's fine, the windows work, the radio sometimes works. When I try to start it, it just makes a clicking sound. The fuses appear to be fine. Could there be a short somewhere? I also had them wash the underbody as well if that helps. Any suggestions would be appreciated. Thanks!
anderson4145 is offline  
Old 12-23-2015, 12:21 AM
  #2  
Junior Member
 
Join Date: Dec 2015
Posts: 1
Default

try removing the distributor cap and drying it out with some electrical cleaner. Any moisture in there will inhibit the current sent through the plug wires.
Bart Rose is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
sabaugebenz
Off Topic
1
01-18-2015 05:40 AM
tpoe5
Detailing
1
02-26-2011 06:27 PM
Saab Fahrer
Saab 9-3
1
03-12-2009 04:53 PM
Autogeek
Detailing
2
01-15-2008 08:47 AM
dashcrash8
New Member Area
1
11-28-2005 03:54 PM


Thread Tools
Search this Thread
Quick Reply: Car won't start after car wash


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.