Go Back  Saab Forums - Saab Enthusiast Forum > Saab Model Line Up > Saab 9-3
newbie - first problem ever with my car >

newbie - first problem ever with my car

newbie - first problem ever with my car

 
Old 01-28-2011, 02:31 PM
  #1  
jan
Junior Member
Thread Starter
 
Join Date: Jan 2011
Posts: 8
Smile newbie - first problem ever with my car

I have a saab 1998 9-3 automatic convertible - owned for 7 years - no problems ever- until now.

Had a couple of times when it would not start - not turn over or anything - then if i waited a few minutes it started fine. Then today it did the same thing - then started ok - went to work and halfway there pulled up behind a car to stop and the lights all went out and it just died on me completely ( in a very dangerous place!)

turned everything off - waited about 10 minutes - then it sarted and I managed to get to work. too scared to drive it home.

As I know nothing about cars after testing the battery tomorrow if it is not that? any ideas ? just so when i get it to the garage I dont get the run around .

thanks
jan is offline  
Old 01-28-2011, 03:17 PM
  #2  
Super Moderator
 
Join Date: Dec 2006
Location: Kiev, UA
Posts: 2,030
Default

Does it only happen when the car is warm?
Roto is offline  
Old 01-28-2011, 04:55 PM
  #3  
jan
Junior Member
Thread Starter
 
Join Date: Jan 2011
Posts: 8
Default

no

it happens mainly when the car is cold.thanks for your reply
jan is offline  
Old 01-29-2011, 12:25 AM
  #4  
Super Moderator
 
Join Date: Dec 2006
Location: Kiev, UA
Posts: 2,030
Default

No check engine light? When it doesn't crank do you hear if the fuel pump is priming? (humming noise from under the rear seat)
Roto is offline  
Old 01-29-2011, 04:15 AM
  #5  
jan
Junior Member
Thread Starter
 
Join Date: Jan 2011
Posts: 8
Default

No I have not heard that. Just been to work to pick it up and its freezing today. Started first time and drove back fine.

Going to try it a couple of times over the weekend when its cold and warm to see what happens.

worse that its intermittent really because its quite hard to explian what happens.

thanks for your help so far

jan
jan is offline  
Old 01-30-2011, 07:05 AM
  #6  
jan
Junior Member
Thread Starter
 
Join Date: Jan 2011
Posts: 8
Default

well today we looked at battery, all fine.

It started first time - drove absolutely fine- no problems at all

sometimes harder when its an intermittent fault as I can not really show anyone what is happening.
jan is offline  
Old 04-16-2011, 09:33 PM
  #7  
Junior Member
 
Join Date: Aug 2008
Posts: 15
Default

Not meaning to threadjack; hoping to compare my similar experience & maybe revive this discussion.
My wife's 2001 9-3 convertible (47K miles) died without warning, stopped at a light.
Engine turned over but would not start.
Wait five minutes, started.
Same thing a couple weeks later.
Very random, so it seems unlikely I could replicate it for a mechanic.

Warm engine, no CEL.

Searched this forum but didn't find anything specific other than this thread.
Suggestions? Opinions?
45guy is offline  
Old 04-17-2011, 06:44 AM
  #8  
jan
Junior Member
Thread Starter
 
Join Date: Jan 2011
Posts: 8
Unhappy

strange that you should post now - just as we have been working on the car. My problem gradually got worse - but it is very difficult to explain to anyone else when they did not see it happen - and it was intermittent.

Last week it eventually became much worse - so when it started sometimes there were dashboard lights but it would not start and then the nxt time there were just very faint lights glowing . sometimes it would start in neutral but not park.

yesterday after much swearing and throwing things around MOH removed and cleaned the switch (NSS?) Very difficult to get at because of the battery metal tray? Or so I am told.Then it started first time - drove it everything was fine - later in the day - went back and it would not start again. Now today just to check if it the problem and as a temporary measure he has done the bypass - if that works and it is the problem then we will buy a new switch ASAP.
At the moment fingers crossed it is starting every time.

Trouble is the car is not worth much now and we dont want to spend loads of money on it - but I am sure the engine has got lots of life in it yet ( low mileage) and I have had no problems other than this in all the time I have owned it. We have to sell it now for practical reasons and all its needs is a bit of TLC
jan is offline  
Old 04-17-2011, 09:30 AM
  #9  
Junior Member
 
Join Date: Aug 2008
Posts: 15
Default

Now that you mention it, we had to replace the neutral safety switch a few years ago.
Its failure prevented predictable starting but never, ever, stalled the car once running.
And that's the challenge at the moment.

NSS = Very expensive.
45guy is offline  
Old 05-02-2011, 10:38 AM
  #10  
jan
Junior Member
Thread Starter
 
Join Date: Jan 2011
Posts: 8
Default more problems

Well NSS switch replaced and all working fine - fingers crossed. The bypass swith worked fine as a temporary measure to prove that was the problem.

We have cleaned /polished and pampered the car as reluctantly we have decided to sell it.

Now the roof wont work! will go up and down very slowly and only by repeatedly using the button with fault messages coming up.
jan is offline  

Thread Tools
Search this Thread
Quick Reply: newbie - first problem ever with my car


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.