Go Back  Saab Forums - Saab Enthusiast Forum > Saab Model Line Up > Saab 9-3
Please Help 9-3 Wipers don't park and no washers >

Please Help 9-3 Wipers don't park and no washers

Please Help 9-3 Wipers don't park and no washers

 
Old 02-12-2010, 01:24 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Jan 2010
Posts: 2
Default Please Help 9-3 Wipers don't park and no washers

Hey all,

I am new here and sorry to not introduce myself properly.

Anyway great forum and I have a $1,000 question.

My car is a 2003 9-3 2.0T Arc

The problem is with my wipers and washers.
They worked fine since a few months ago. I get 3 speeds (technicly 2 speeds Hi and low). My wipers do not park, the onlyway to get them back in posistion is by manualy shutting them off when they rest. I also do not get any wiper spray or headleamp spray.

Now for the past 3 months the spray never worked along with the wiper problem, ironicly 4 weeks ago I made a sharp turn and hit a little bumb and "they worked until I turned the car off" They worked, but not at full pressure, and wiper blades still wouldnt park. Also this past week I brought it in the repair shop to get inspected and I parked the car on a slight incline and just as I was showing the mechanic how they didnt worked, it worked again. But after he turned the car off and brought it in, nothing again.

He is a highly reputable mechanic and he is baffled with this, he tried replacing the switch but nothing. The next step unfortunatly I may have to take is bring it into the dealership and it will cost $1000 or more.

Any suggestions, even just to get the window washers to work?

Thanks All
Thebutcher is offline  
Old 02-18-2010, 12:19 PM
  #2  
Super Moderator
 
Join Date: Dec 2006
Location: Kiev, UA
Posts: 2,030
Default

Hey there. I can take a look at it if you'd like. Never heard of that being a common problem, but there's not much to that system.
Roto is offline  
Old 02-19-2010, 10:34 AM
  #3  
Junior Member
Thread Starter
 
Join Date: Jan 2010
Posts: 2
Default

Thanks Roto,

I think the mechanic may of found out, he said he thinks it is the wiper motor after talking to others, he said there is a park switch is in the motor and if that is malfunctioned, the wipers won't park (which is happening). Also it wont spray because somewhow the system is hooked up.

I will let you know how it goes, I think he is putting in a used wiper motor in it today or Monday. If this doesn't work, I can have you take a look at it and hook you up.The car is in Huntingdon Valley now so probably not to far away. The problem I am having is that it needs to pass inspection and it won't pass unless the washers work I will let you know the updates

Thanks
Thebutcher is offline  
Old 07-06-2011, 12:51 PM
  #4  
Junior Member
 
Join Date: Jul 2011
Posts: 1
Default

Any update on this i have a similiar problem, my wash and wipers worked one minute then after washing the screen the water stopped and so did the wipers, a little later they seemed to work fine for a few days and now its happened again and the wipers remain in the upright position.

Cheers Steve
eggopp is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Patrick Prince
General Auto Related Help Area
0
08-18-2016 03:31 PM
Saab Fahrer
Saab 9-3
1
03-12-2009 04:53 PM


Thread Tools
Search this Thread
Quick Reply: Please Help 9-3 Wipers don't park and no washers


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.