Go Back  Saab Forums - Saab Enthusiast Forum > Saab Model Line Up > Saab 9-3
 SID Displays "TELEPHONE" and car won't start >

SID Displays "TELEPHONE" and car won't start

SID Displays "TELEPHONE" and car won't start

 
Old 01-08-2009, 05:28 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Jan 2009
Posts: 6
Default SID Displays "TELEPHONE" and car won't start

Ok, i went out to my 2001 Saab 9-3 2dr and the keyless entry didn't work. no big deal. got in with the key, turned on the battery, all the displays come up but the SID displays "TELEPHONE". I've never used a phone adapter or anything and the on star system isn't in use or activated. So i turn the key, it tries to turn over unsuccessfully, and then makes an unusual clicking until i let the key go. Upon trying to turn the key and start it again it has locked and will not allow me to turn the key to start it. Then when i tried to use keyless to lock it, it worked, then a moment later unlocked itself and i had to lock the doors and trunk manually. Does anyone know what might be wrong with it?

Earlier today before i realized it wouldn't start the car alarm went off randomly and upon investigating to make sure nobody tried to break in, all i noticed was the keyless entry was doing the same things but at that point i didn't try to start it. it wasn't till just now i found out it wont start...

Please Help!
Has anyone else had this problem?
bwainwri is offline  
Old 01-11-2009, 06:20 AM
  #2  
Junior Member
 
Join Date: Nov 2008
Posts: 5
Default RE: SID Displays "TELEPHONE" and car won't start

and I though I was having some weird issues, It sounds like you are having multi failures across the board. If I were in your shoes I would try to clear evrythjing by disconnecting the battey for about 30 minutes. Can't hurt anything and itshould clearall codes if there are any, is you engine light on?
roadvision is offline  
Old 01-12-2009, 04:11 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Jan 2009
Posts: 6
Default RE: SID Displays "TELEPHONE" and car won't start

No, the engine light wasn't on. Got everything under control though. i think i must have mistakenly turned on and left on the onstar system which is why the SID displayed "TELEPHONE" and then it killed my battery explaining the not starting and locks not working. I'm glad it was just that, i thought my baby was seriously ill for a minute there.
bwainwri is offline  
Old 01-20-2009, 02:26 PM
  #4  
Junior Member
 
Join Date: Jan 2009
Location:
Posts: 7
Default RE: SID Displays "TELEPHONE" and car won't start

Try replacing the battery. I sell cars and a lot of times when the batteries are dead or bad, the motor just clicks when you try to start it, and also the just freaks out, random alarms going off and what not. If a new batter don't work, check the altenator and cables between it and the battery. My moms cars did that once ( not a Saab) and there was a short in the cable between the altenator and the battery so it wasn't recharging. Just a thought
swedestsaab2006 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Canada_Saab
Saab 9-3
0
11-06-2016 09:36 AM
tri18
Saab 9-5
5
04-21-2015 01:28 AM
Snyderg167
Saab 9-3
14
04-23-2014 06:07 AM
jtellis2
PRIVATE For Sale / Trade Classifieds
5
11-17-2008 06:56 PM
Off Topic
1
10-12-2005 01:58 PM


Thread Tools
Search this Thread
Quick Reply: SID Displays "TELEPHONE" and car won't start


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.