Go Back  Saab Forums - Saab Enthusiast Forum > Saab Model Line Up > Saab 9-3
 sid traction control/stability control/abs failure >

sid traction control/stability control/abs failure

sid traction control/stability control/abs failure

 
Old 10-15-2008, 02:46 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Oct 2008
Posts: 2
Default sid traction control/stability control/abs failure

hi people i am only new, i have a late 05 93 vector sport tid 150 bhp

the above problem all popped up in one go today on my sid,does anyone know how this could come about and more importantly am i talking hundreds of £ to get it sorted

many thanks
seansaab is offline  
Old 10-15-2008, 04:20 PM
  #2  
Super Moderator
 
Join Date: Dec 2006
Location: Kiev, UA
Posts: 2,030
Default RE: sid traction control/stability control/abs failure

Hard to tell without diagnostics. It could be as simple as a bad ground, or it could be a real problem. Take it to a dealer to get it scanned with a Tech II.
Roto is offline  
Old 03-19-2013, 11:17 AM
  #3  
Junior Member
 
Join Date: Dec 2010
Posts: 1
Default Solution: ABS Failure / Traction Control Failure / Stability Control Failure

Originally Posted by seansaab View Post
hi people i am only new, i have a late 05 93 vector sport tid 150 bhp

the above problem all popped up in one go today on my sid,does anyone know how this could come about and more importantly am i talking hundreds of £ to get it sorted

many thanks
I had this exact issue - whilst driving, one after the other, the three warnings popped up on the SID display and could not be cleared. The first time it happened, when I stopped driving, parked and restarted it cleared it for about 8 minutes - then it happened again. Second time I reset it lasted for ten mins, then happened again. Thereafter, the warning were permanently on as soon as the ignition key was inserted and the key turned.

I called my local Saab specialist who is fantastic and they clearly know these cars inside out. He told me over the phone that the likeliest cause for this was the wiring to one of the speed sensors on one of the rear wheels had become damaged. If it was, would be a twenty minute fix to cut out the corroded wiring and solder in some some new sections.

Was booked in, and the Tech 2 confirmed that the problem was reported with the n/s rear wheel sensor. Sure enough, when the cabling was exposed a section of the bare wire was visible and corroded. Apparently, when the cabling is fitted and then covered in the poly wrap, it is attached to the suspension assembly with a cable-tie and this rubs & wears over time breaking the cable. Just one of those things.

Upon restarting the car, all warnings cleared, no parts required and car fixed - thanks to Motorvation Saab in Tonbridge for once again not fleecing me with my 9-3! 50 - total bill.
rjsdavis is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Canada_Saab
Saab 9-3
0
11-06-2016 09:36 AM
alanaberdeen
Saab 9-3
3
11-22-2015 04:21 PM
the blaab
Saab 9-3
0
02-14-2010 08:58 PM
carldamien
General Auto Related Help Area
0
11-01-2009 10:12 PM
tallguy04
Saab 9-3
0
05-31-2009 08:26 AM


Thread Tools
Search this Thread
Quick Reply: sid traction control/stability control/abs failure


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.