Strange Coolant Temp Issue

 
Old 02-19-2013, 04:52 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Feb 2013
Posts: 1
Default Strange Coolant Temp Issue

Good morning,

This is my first post on the forums and i hope to visit more often, i was wondering if anyone could help with a problem I have.

My 2005 93 2.0t temp gauge doesnt bottom out when the ignition is off and sits around the halfway point - when the engine is up to temperature it is off the scale past the red zone. The engine is not overheating and this looks like a temp sensor issue to me ( I drove the car 300 miles yesterday in this condition such was my conviction that the engine was fine and it was an indication issue)

Am i correct that a straight temp sensor replacement will sort this issue ?

Many thanks in advance for your replies
Ian Middlemiss is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Dahall99Saab95
New Member Area
1
03-12-2013 06:08 AM
drglock
1994-1994 900
0
10-19-2011 11:02 AM
familyfleetguy
Saab 9-5
1
02-04-2011 05:41 PM
Thor170
Saab 9-3
0
12-03-2010 01:20 PM
Exhevizion
Saab 9-3
1
06-09-2008 10:44 PM


Thread Tools
Search this Thread
Quick Reply: Strange Coolant Temp Issue


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.