Turbo "pinging" noise

 
Old 09-22-2010, 09:49 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Sep 2010
Posts: 1
Default Turbo "pinging" noise

I have a 2004 9-3 with the 2.0t. 94K miles. I recently had the timing chain, tentioners, guides and water pump chain replaced. Both chains are tight with very little slack. The car runs fantastic except for one thing,

When I accelate and the turbo nears the red line, I get a pinging noise. This happens for a while and then goes away once the car has been driven for a while. Once driven, especially on a long trip, I can hit maxium boost without any noise at all. Now something that is interesting is, that I can get the engine to rev to 3500 - 4000 rpm while in park and not get any noise at all.

When the noise occurs, it comes from the area where the turbo is located. I'm not 100% convinced that it is the turbo, but can't figure out what is causing the ping. Any help is appreciated.

Thanks,

Taget
Target is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Canada_Saab
Saab 9-3
0
11-06-2016 09:36 AM
davburner
Saab 9-3
0
07-29-2013 10:05 AM
info2
Saab 9-5
0
05-14-2013 07:16 AM
Kyle22rte
Saab 9-5
8
07-27-2011 11:18 PM
reidg
Saab 9000
12
03-07-2010 03:15 PM


Thread Tools
Search this Thread
Quick Reply: Turbo "pinging" noise


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.