Go Back  Saab Forums - Saab Enthusiast Forum > Saab Model Line Up > Saab 9-3
Left low beam failure, not the bulb >

Left low beam failure, not the bulb

Left low beam failure, not the bulb

 
Old 02-23-2014, 01:24 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Feb 2014
Location: Sweden
Posts: 1
Default Left low beam failure, not the bulb

So, I have my 2003 9-3 Vector with Halogen-lights.
Today, the left low beam went out.
But the bulb was not broken, but I switched it anyways and no luck, it will not turn on.

All other lights are ok, high beam and parking and so on.
What could be the problem?

http://www.garaget.org/?car=269155

EDIT:


I checked the high-beam bulb..
Feeling a little bit retarded at the moment.


Last edited by SirMacke; 02-23-2014 at 02:35 PM.
SirMacke is offline  
Old 03-23-2014, 08:40 PM
  #2  
Junior Member
 
Join Date: Mar 2014
Posts: 1
Default

I have HID's and similar thing happened to me last week. Then I noticed a loose wire was the culprit. Not sure the halogen ones have this wire, but may be worth double checking that nothing is loose. I know it's not much advise, but I figure I'd share my experience.
Luder is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
raboni
Saab 9-3
2
10-16-2012 02:43 AM
redman73096
Saab 9-3
1
08-18-2012 08:07 AM
cjharris02892
Saab 9-3
0
02-28-2012 07:26 PM
blubirdinny
Saab 9-3
0
02-19-2010 07:46 PM
bavario
Saab 9-5
10
11-15-2008 09:40 PM


Thread Tools
Search this Thread
Quick Reply: Left low beam failure, not the bulb


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.